Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10140

puppet service and puppet-agent failing on windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 5.5.18, PUP 6.4.5, PUP 6.12.0
    • Component/s: None
    • Labels:
      None
    • Template:
      PUP Bug Template
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      2019-11-27
    • Method Found:
      Automated Test
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      Installing the puppet-agent on windows platforms isn't generating a CSR, and I've also encountered problems with manually trying to start the puppet service in general on windows platforms. This started cropping up in PE 2018.1.x CI, tests started failing because CSRs were not showing up when the tests expected them to.

      An example of the failure can be seen in this Agent Integration job for PE 2018.1.x, with a puppet-agent SHA of 5.5.17.71.gb6ebce3

        Attachments

          Activity

            People

            Assignee:
            gheorghe.popescu Gheorghe Popescu
            Reporter:
            barr.iserloth Barr Iserloth
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support