Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1015

Error: Could not intialize global default settings: undefined method `mode=' for #<Puppet::Settings::AutosignSetting:0x7ff361614368>

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: PUP 3.4.0 RC
    • Fix Version/s: PUP 3.4.2
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2013-12-11 to 2013-12-18, Week 2013-12-19 to 2014-1-2

      Description

      Follow-on from #23349... regression from 3.3.x to 3.4.0-rc2. This affects all Foreman users, since it's the default installer configuration (https://github.com/theforeman/puppet-puppet/blob/master/templates/puppet.conf.erb#L21).

      With this in puppet.conf:

      [main]
          autosign       = $confdir/autosign.conf { mode = 664 }
      

      # puppet --version
      Error: Could not intialize global default settings: undefined method `mode=' for #&lt;Puppet::Settings::AutosignSetting:0x7f4b4ecff440&gt;
      # rpm -q puppet
      puppet-3.4.0-0.1rc2.el6.noarch
      

      Sorry for not including the full puppet.conf entry in the earlier bug report, we could have avoided a round trip.

        Attachments

          Issue Links

            Activity

            Hide
            domcleal Dominic Cleal added a comment -

            If you're managing mode for autosign.conf in puppet.conf today, like the default Foreman setup:

                # Puppet 3.0.x requires this in both [main] and [master] - harmless on agents
                autosign       = $confdir/autosign.conf { mode = 664 }
            

            Comment out this line for 3.4.0, but remember to uncomment it again for 3.4.1, else the file mode will reset back to the default!

            Show
            domcleal Dominic Cleal added a comment - If you're managing mode for autosign.conf in puppet.conf today, like the default Foreman setup: # Puppet 3.0.x requires this in both [main] and [master] - harmless on agents autosign = $confdir/autosign.conf { mode = 664 } Comment out this line for 3.4.0, but remember to uncomment it again for 3.4.1, else the file mode will reset back to the default!
            Hide
            kurt.wall Kurt Wall added a comment -

            Verified in puppet-3.4.0.317-1.el6.noarch:

            # puppet config set autosign '$confdir/autosign.conf { mode = 644 }' --section main
            # cat /etc/puppet/puppet.conf 
            [main]
                # The Puppet log directory.
                # The default value is '$vardir/log'.
                logdir = /var/log/puppet
             
                # Where Puppet PID files are kept.
                # The default value is '$vardir/run'.
                rundir = /var/run/puppet
             
                # Where SSL certificates are kept.
                # The default value is '$confdir/ssl'.
                ssldir = $vardir/ssl
            autosign = $confdir/autosign.conf { mode = 644 }
             
            # puppet --version
            3.4.0
            # rpm -q puppet
            puppet-3.4.0.317-1.el6.noarch
            

            Show
            kurt.wall Kurt Wall added a comment - Verified in puppet-3.4.0.317-1.el6.noarch: # puppet config set autosign '$confdir/autosign.conf { mode = 644 }' --section main # cat /etc/puppet/puppet.conf [main] # The Puppet log directory. # The default value is '$vardir/log'. logdir = /var/log/puppet   # Where Puppet PID files are kept. # The default value is '$vardir/run'. rundir = /var/run/puppet   # Where SSL certificates are kept. # The default value is '$confdir/ssl'. ssldir = $vardir/ssl autosign = $confdir/autosign.conf { mode = 644 }   # puppet --version 3.4.0 # rpm -q puppet puppet-3.4.0.317-1.el6.noarch
            Hide
            domcleal Dominic Cleal added a comment -

            Note, this wasn't released in 3.4.1 as the ticket says - 3.4.1 was a security release and this patch seems to have been held back. Presumably it'll go out in 3.4.2 instead.

            Show
            domcleal Dominic Cleal added a comment - Note, this wasn't released in 3.4.1 as the ticket says - 3.4.1 was a security release and this patch seems to have been held back. Presumably it'll go out in 3.4.2 instead.
            Hide
            melissa Melissa Stone added a comment -

            Released in Puppet 3.4.2

            Show
            melissa Melissa Stone added a comment - Released in Puppet 3.4.2

              People

              • Assignee:
                Unassigned
                Reporter:
                redmine.exporter redmine.exporter
              • Votes:
                1 Vote for this issue
                Watchers:
                13 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support