Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10352

Puppet agent total run time reported doesn't match time elapsed between Start and End event logs in Windows

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Normal
    • Resolution: Won't Fix
    • PUP 5.5.14
    • None
    • Windows
    • Night's Watch
    • 3
    • NW - 2020-03-17, NW - 2020-04-29
    • Needs Assessment
    • 38131,38849
    • 2
    • Not Needed
    • Needs Assessment

    Description

      Puppet interval run on Windows nodes will only log the following two event logs, for example,

      1:25:32 AM: "Executing agent with arguments:"
      1:26:43 AM: "Applied catalog in 1.82 seconds"

      This implies the start and end of a full Puppet run (about 1m11s). However, from the report submitted, the Puppet agent running time is much less than the elapsed time between the above two events.

      -------------

      Total runtime (sec):20.12
      Config retrieval time (sec):0.99
      Fact generation (sec):5.82
      Transaction evaluation (sec):1.87
      Convert catalog (sec):0.86
      Node retrieval (sec):0.23
      Plugin sync (sec):10.16
      Time to apply (sec):1.99

      --------------

       

       

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              henry.wang Henry Wang
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support