Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10355

Can't disable Puppet::SSL::Host deprecation warning when using puppetdb terminus

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 6.15.0
    • Component/s: None
    • Labels:
    • Template:
      PUP Bug Template
    • Epic Link:
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Puppet no longer generates a deprecation warning when calling "Puppet::Network::HttpPool.http_instance" as used to happen when using the puppetlabs-puppetdb module to install and manage puppetdb.
    • QA Risk Assessment:
      Needs Assessment

      Description

      PuppetDB module uses deprecated in puppet 6.8.0 function, causing a warning:

      Warning: Puppet::SSL::Host is deprecated and will be removed in a future release of Puppet.
       
         (location: /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/ssl/host.rb:235:in `initialize')
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              josh Josh Cooper
              Reporter:
              vchepkov Vadym Chepkov
              Votes:
              6 Vote for this issue
              Watchers:
              15 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support