Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10469

Portage package provider doesn't work on Gentoo-based distributions

    XMLWordPrintable

    Details

    • Template:
      PUP Bug Template
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      NW - 2020-05-13
    • Method Found:
      Needs Assessment
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Hide
      Thanks https://github.com/ananace,
      Fixed a bug where the Gentoo provider was not correctly selected on Gentoo-family distributions.
      Show
      Thanks https://github.com/ananace, Fixed a bug where the Gentoo provider was not correctly selected on Gentoo-family distributions.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Puppet Version: 6.13.0
      Puppet Server Version: 6.10.0
      OS Name/Version:  Sabayon Linux 20.03

      The portage provider in Puppet confines to only operatingsystem gentoo, which won't work on distributions based on Gentoo.

      Desired Behavior:

      The portage provider works on all Gentoo-family distributions.

      Actual Behavior:

      Error: /Package[net-misc/choria-bin]: Provider portage is not functional on this host

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            ananace Alexander Olofsson
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support