Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10625

Bump minimum required version to Ruby 2.5

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 7.0.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      NW - 2020-09-01
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      The minimum Ruby version required to run Puppet was updated to 2.5 for Puppet 7
    • QA Risk Assessment:
      Needs Assessment

      Description

      On Platform 7 we will no longer support versions of Ruby that have gone end of life: 2.3 and 2.4.

      To achieve this we need to do the following on the Puppet main stream:

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gabriel.nagy Gabriel Nagy
              Reporter:
              mihai.buzgau Mihai Buzgau
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support