Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10841

Remove ruby < 2.5 monkey patches

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Normal
    • Resolution: Duplicate
    • None
    • None
    • None
    • None
    • Needs Assessment
    • Needs Assessment

    Description

      puppet#main includes several monkey patches for ruby < 2.5, eg. OpenSSL, Enumerable, etc. Now that puppet#main requires ruby 2.5 or greater many of those monkey patches can be removed.

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              josh Josh Cooper
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support