Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10843

Module tool should check for Forge modules compatibility with running versions of Puppet and Facter

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PMT
    • Template:

      Description

      Once module authors have the option to specify compatible Puppet and Facter versions, the module tool should check for this data and provide the user useful feedback if they attempt to install a module that's incompatible with their environment.

      Useful feedback could be things like offering versions of the module that are compatible with their environment or as simple as not installing the module and offering a reason why.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            redmine.exporter redmine.exporter
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support