Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-10851

Error "Entry 'allow *' is unsupported and will be ignored" shown during PE upgrade

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 7.3.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Coremunity
    • Sprint:
      Platform Core KANBAN
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Hide
      Puppet no longer prints an error if fileserver.conf contains "allow *" rules. It will continue to print an error for all other rules, since puppet's legacy authorization is no longer supported and is completely superseded by puppetserver's authorization.
      Show
      Puppet no longer prints an error if fileserver.conf contains "allow *" rules. It will continue to print an error for all other rules, since puppet's legacy authorization is no longer supported and is completely superseded by puppetserver's authorization.
    • QA Risk Assessment:
      Needs Assessment

      Description

      The error Entry 'allow *' is unsupported and will be ignored shows up when upgrading to PE 2021 with Puppet 7.  Since the file is managed to remove this entry once the puppet run that upgrades the primary completes (https://github.com/puppetlabs/puppet-enterprise-modules/commit/e7659a96562dced9fdd09b850c5a7947bed7043c), it would be great to be able to either suppress this message, or remove it if it is unnecessary.

        Attachments

          Activity

            People

            Assignee:
            josh Josh Cooper
            Reporter:
            nick.burgan-illig Nick Burgan
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support