Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-11323

Puppet agent runs in environment specified on CLI when not in an agent specified environment

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • High
    • Resolution: Incomplete
    • PUP 6.25.0
    • None
    • None
    • None
    • Needs Assessment
    • Needs Assessment

    Description

      Puppet Version: 6.25
      Puppet Server Version: 2019.8.9
      OS Name/Version: tested on centos7

      Puppet agent runs in environment specified on CLI when not in an agent specified environment

      Desired Behavior: 

      In Puppet 6.24 the behaviour is as expected, if a CLI environment is specified but the agent is not in a agent specified node group the run outputs a notice and continues in the server specified environment:

      [root@pe-node-48716e-0 ~]# puppet agent -t --environment=testing
      Notice: Local environment: 'testing' doesn't match server specified node environment 'production', switching agent to 'production'.

      Actual Behavior:

      After upgrading to 6.25 it runs in the CLI specified environment:

      [root@pe-node-48716e-0 ~]# puppet agent -t --environment=testing
      Info: Using environment 'testing'

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              elaine.mccloskey Elaine McCloskey
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support