Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1243

PR (2184): (maint) Fix can't modify frozen Symbol error on Ruby 2.1.0 - jeffmccune

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.5.0
    • Component/s: Community
    • Labels:
    • Template:

      Description

      (maint) Fix can't modify frozen Symbol error on Ruby 2.1.0

      Pull Request Description


      Without this patch we're getting the following error on Ruby 2.1.0:
      `can't modify frozen Symbol (Puppet::Error)`. This problem is caused by
      our monkey patching which attempts to cache Symbol#to_proc return values
      instead of creating new instances on every call.

      As it turns out, the caching optimization is not necessary on Ruby 1.9.3
      and later because Symbol#to_proc implements its own caching system in
      these versions.


      (webhooks-id: baa2dadb795175b0f2948515617e7ad2)

        Attachments

          Issue Links

            Activity

            gepetto-bot gepetto-bot added a comment -

            puppetcla commented:

            CLA signed by all contributors.

            gepetto-bot gepetto-bot added a comment -

            Pull request (maint) Fix can't modify frozen Symbol error on Ruby 2.1.0 has been closed.

            rob Rob Reynolds added a comment -

            This PR was merged.

            rylon Ryan Conway added a comment -

            Hey there, just wondering what the status of this PR was, in terms of the 3.5.0 release? We're not able to roll out Ruby 2.1.0 because of this issue you see. Cheers!


              People

              • Assignee:
                Unassigned
                Reporter:
                gepetto-bot gepetto-bot
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support