Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1282

puppet gem does not include platform specific gem dependencies

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.5.0
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-1-15 to 2014-1-21, Week 2014-1-22 to 2014-1-29, Week 2014-1-29 to 2014-2-05, Week 2014-2-5 to 2014-2-12, Week 2014-2-12 to 2014-2-19

      Description

      The puppet gem on windows has dependencies on win32-dir, etc, but these are not expressed in the gemspec file. So if you are developing a module, and attempt to `bundle install`, the transitive dependencies are not satisfied. The same issue exists in facter and hiera.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              redmine.exporter redmine.exporter
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support