Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1519

Package resource should allow ensure=>">1.0" or ensure=>"<0.10" as well as 'latest', 'installed' and specific version number

    XMLWordPrintable

    Details

    • Epic Name:
      Package resource should allow version constraint
    • Template:
    • Team/s:
      Night's Watch
    • Sprint:
      PR - Triage
    • CS Priority:
      Reviewed
    • Zendesk Ticket IDs:
      38194
    • Zendesk Ticket Count:
      1
    • Release Notes:
      Not Needed

      Description

      It would be helpful if the 'ensure' parameter to the Package resrouce could also specify 'at least version *x' and 'no later than version **y*' as well as 'latest version', 'installed' (IE, any version) or a specific version number.

      EG:

          package { 'foo': ensure=>'>1.0' }
      

      would act as 'latest' if the current package was uninstalled or version before 1.0, but would act as 'installed' otherwise. Similarly,

          package { 'foo': ensure=>'<4.0' }
      

      would act as 'installed' if version is <4.0 but would produce an error otherwise.

      This would allow us to set a manifest to avoid packages with known problems in a certain version, but not upgrade unless necessary.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              redmine.exporter redmine.exporter
              QA Contact:
              Eric Thompson
              Votes:
              32 Vote for this issue
              Watchers:
              45 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support