Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1626

dpkg provider works incorrect on non english locales

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: PUP 3.4.2
    • Fix Version/s: PUP 4.6.2
    • Component/s: None
    • Labels:
    • Environment:

      Ubuntu 12.04

    • QA Risk Assessment:
      No Action
    • QA Risk Assessment Reason:
      Cannot reproduce

      Description

      regular expression:

      self::DPKG_PACKAGE_NOT_FOUND_REGEX = /no package.*match/i

      doesn't work on non english locales, for example on uk_UA locale dpkg-query return:

      # /usr/bin/dpkg-query -W --showformat '${Status} ${Package} ${Version} :DESC: ${Description}\n:DESC:\n' somepackage

      Шаблону somepackage не відповідає жоден пакунок.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                RoMan Roman Shipovskij
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support