Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1735

Puppet::Node::Environment.current should reroute with deprecation warning

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.5.0
    • Fix Version/s: PUP 3.5.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-2-19 to 2014-2-26

      Description

      PUP-1118 in commit ecb317b removed Puppet::Node::Environment.current, which I've seen used in two places:

      I'm worried that there might be other users of this, so would suggest it's rerouted to the `Puppet.lookup(:current_environment)` call and prints a deprecation warning to this ticket.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                domcleal Dominic Cleal
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support