Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1760

Update win32-security gem to latest (after string_to_sid fix)

    XMLWordPrintable

Details

    • Task
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • PUP 3.7.0
    • None

    Description

      Hoping for 3.5.0 but not a blocker.

      We have a small blocker to upgrading to the latest win32-security gem. It seems to truncate the
      binary representation of the SID when calling Win32::Security::SID.string_to_sid('some sid'). We rely on this method in several places so we need to get this fixed prior to upgrading our gem. For more information, please see the link for Win32-Security Issue.

      This is not a "Security" issue in our sense of the term.

      Attachments

        Issue Links

          Activity

            People

              rob Rob Reynolds
              rob Rob Reynolds
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support