Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1911

Windows installer downgrade fails to start service, exits with code 1603

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: PUP 3.4.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      2

      Description

      A simple set of repro steps is as follows:

      • Install PE 3.2.0
      • Try to install PE 3.1.2

      The PE 3.1.2 installer will successfully install PE 3.2.0, and during the install of PE 3.1.2 will fail with a generic MSI installation code:
      ERROR_INSTALL_FAILURE 1603 Fatal error during installation

      If run through the UI, you can see that files are copied correctly, and a start of the pe-puppet / puppet service will be triggered. Unfortunately it appears that the installer believes that the service has failed to start.

      The relevant portion of the log starts at line 160328 of the attached log file.

      MSI (s) (F4:78) [10:49:41:046]: Executing op: ServiceInstall(Name=pe-puppet,DisplayName=Puppet Agent,ImagePath="c:\Program Files (x86)\Puppet Labs\Puppet Enterprise\service\daemon.bat",ServiceType=16,StartType=2,ErrorControl=32769,,Dependencies=[~],,StartName=LocalSystem,Password=**********,Description=Periodically fetches and applies configurations from a Puppet master server.,,)
      MSI (s) (F4:78) [10:49:41:087]: Executing op: ServiceInstall(Name=pe-mcollective,DisplayName=Marionette Collective Server,ImagePath="c:\Program Files (x86)\Puppet Labs\Puppet Enterprise\service\mco_daemon.bat",ServiceType=16,StartType=3,ErrorControl=32769,,Dependencies=[~],,StartName=LocalSystem,Password=**********,Description=Puppet Labs server orchestration framework,,)
      MSI (s) (F4:78) [10:49:41:094]: Executing op: ActionStart(Name=StartServices,Description=Starting services,Template=Service: [1])
      MSI (s) (F4:78) [10:49:41:094]: Executing op: ProgressTotal(Total=1,Type=1,ByteEquivalent=1300000)
      MSI (s) (F4:78) [10:49:41:094]: Executing op: ServiceControl(,Name=pe-puppet,Action=1,Wait=1,)
      MSI (s) (F4:78) [10:50:11:894]: Note: 1: 2205 2: 3: Error
      MSI (s) (F4:78) [10:50:11:894]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1920
      MSI (s) (F4:78) [10:50:11:895]: Note: 1: 2205 2: 3: Error
      MSI (s) (F4:78) [10:50:11:895]: Note: 1: 2228 2: 3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709
      MSI (s) (F4:78) [10:50:11:895]: Product: Puppet Enterprise – Error 1920. Service 'Puppet Agent' (pe-puppet) failed to start. Verify that you have sufficient privileges to start system services.

      Error 1920. Service 'Puppet Agent' (pe-puppet) failed to start. Verify that you have sufficient privileges to start system services.
      MSI (s) (F4:78) [10:50:11:901]: User policy value 'DisableRollback' is 0
      MSI (s) (F4:78) [10:50:11:901]: Machine policy value 'DisableRollback' is 0
      Action ended 10:50:11: InstallFinalize. Return value 3.

      If the PE 3.1.2 installer is started again, the install completes and the service is started.

      Complete log is attached as a zip.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  ethan Ethan Brown
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support