Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-1951

Unable to "Run Facter" or "Run Puppet Agent" from Start Menu on Windows 8/2012 - Requires .NET Framework 3.5 installed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.6.1
    • Component/s: None
    • Labels:
      None
    • Environment:

      Windows 2012 R2 running in Azure

    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-4-30 to 2014-5-7, Week 2014-5-7 to 2014-5-14

      Description

      With Windows 2012, installing the puppet MSI (3.5.0-rc1 in this case) and then trying to run the "Run Facter" or "Run Puppet Agent" commands from the Start Menu will result in an error that it needs the .NET Framework version 3.5 in order to run and it cannot install it.

      However "Start Command Prompt With Puppet" works without issue.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                andy Andrew Parker
              • Votes:
                0 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: