Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2093

PMT should use the Forge's /v3 API

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.6.0
    • Component/s: Modules
    • Labels:
      None
    • Template:
    • Story Points:
      3

      Description

      The PMT has been using an outdated, obsolete, and unscalable API for some time now. In an effort to deprecate those legacy APIs, we should update the PMT to use the more sustainable /v3 API.

      One side-effect of this change is that we will be forced to handle all dependency resolution in the PMT (since the server-side dependency resolution was not sustainable). We should endeavor to handle that as elegantly as possible.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              pieter Pieter van de Bruggen
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support