Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2104

Make puppet able to configure a facter implementation to use

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.5.0
    • Fix Version/s: PUP 3.7.0
    • Component/s: Catalog Application
    • Labels:
      None
    • Environment:

      This would allow puppet to plugin alternate facter implementations. Since puppet defaults.rb relies on facter in a few places, some work will be required there, perhaps to lazy-interpret uses of facter.

    • Template:
    • Story Points:
      3
    • Sprint:
      Week 2014-5-28 to 2014-6-4, Week 2014-6-11 to 2014-6-18, Week 2014-6-18 to 2014-6-25, Week 2014-6-25 to 2014-7-9

      Attachments

        Issue Links

          Activity

            People

            • Assignee:
              kylo Kylo Ginsberg
              Reporter:
              kylo Kylo Ginsberg
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support