Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2191

Python pip provider does not support minimum or maximum requirement specifiers

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Do
    • Affects Version/s: PUP 3.4.3, PUP 3.5.0 RC, PUP 3.5.0
    • Fix Version/s: None
    • Component/s: Types and Providers
    • Labels:
      None
    • Template:

      Description

      The Python php package provider does not support pip requirements specifiers other than a specific version.

      The issue seems to be missing quotes around the package and version in the command line args. See: line 85 in pip.rb

      Examples of pip requirements specifiers:

      pip install 'foo==1.0'
      pip install 'foo>=1.0.0'
      pip install 'foo>=1.0.0,<1.5.0'
      

      PIP Install Example Docs
      Valid Specifiers in EBNF

        Attachments

          Activity

            People

            • Assignee:
              kylo Kylo Ginsberg
              Reporter:
              dbeckham Daniel Beckham
              QA Contact:
              Narmadha Perumal
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support