Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2215

An existing directory environment will use config_version from an underlying legacy environment of the same name.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: PUP 3.5.0, PUP 3.5.1 RC
    • Fix Version/s: PUP 3.6.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      2
    • Sprint:
      Week 2014-4-16 to 2014-4-23

      Description

      Nicholas Fagerlund also noticed the following excitement:

      Given a puppet.conf:

      environmentpath=$confdir/environments
      [legacy]
      config_version = /usr/bin/false

      And a directory $confdir/environments/legacy

      then you have:

      [root@ueu8qnql450gx07 ~]# puppet agent -t --environment legacy
      Info: Retrieving pluginfacts
      Info: Retrieving plugin
      Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Execution of config_version command `/usr/bin/false` failed: Execution of '/usr/bin/false' returned 1:  on node ueu8qnql450gx07.delivery.puppetlabs.net
      Warning: Not using cache on failed catalog
      Error: Could not retrieve catalog; skipping run

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                joshua.partlow Joshua Partlow
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support