Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2271

yumrepo attributes cannot be set to '_none_'

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.5.1
    • Fix Version/s: PUP 3.7.0
    • Component/s: Types and Providers
    • Labels:
      None
    • Environment:

      CentOS 6.5, Puppet 3.5.0

    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-4-09 to 2014-4-16, Week 2014-4-23 to 2014-4-30, Week 2014-4-16 to 2014-4-23, Week 2014-4-30 to 2014-5-7, Week 2014-5-7 to 2014-5-14, Week 2014-5-14 to 2014-5-21, Week 2014-5-21 to 2014-5-28, Week 2014-5-28 to 2014-6-4, Week 2014-6-11 to 2014-6-18, Week 2014-6-18 to 2014-6-25

      Description

      The yumrepo attribute cannot be set to the value "none" even though this is a supported value for the yum proxy parameter. We should fix this.

      $ puppet apply -e "yumrepo {'base': proxy => '_none_'}"
      Notice: Compiled catalog for localhost.localdomain in environment production in 0.03 seconds
      Error: Parameter proxy failed on Yumrepo[base]: Validate method failed for class proxy: Must be a valid URL at line 1
      Wrapped exception:
      Validate method failed for class proxy: Must be a valid URL
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              kurt.wall Kurt Wall
              QA Contact:
              Narmadha Perumal Narmadha Perumal
              Votes:
              8 Vote for this issue
              Watchers:
              17 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support