Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2317

Future parser does not error on import statements

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: PUP 3.5.1
    • Fix Version/s: PUP 3.6.0
    • Component/s: Modules
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-4-23 to 2014-4-30, Week 2014-4-30 to 2014-5-7

      Description

      Puppet 3.5.1 with Future parser enabled does not fail on import statements. When parser is set to current it correctly warns the user that import is deprecated.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              blkperl William Van Hevelingen
              Votes:
              1 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support