Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2566

Debian puppet packages set templatedir which triggers deprecation warning

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.5.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Week 2014-5-14 to 2014-5-21

      Description

      If you install puppet from a package, it sets templatedir:

      [main]
      logdir=/var/log/puppet
      vardir=/var/lib/puppet
      ssldir=/var/lib/puppet/ssl
      rundir=/var/run/puppet
      factpath=$vardir/lib/facter
      templatedir=$confdir/templates
      

      This causes a deprecation warning every time you run puppet:

      root@ubuntu1310:/var/lib/puppet# puppet cert list --all
      Warning: Setting templatedir is deprecated. See http://links.puppetlabs.com/env-settings-deprecations
         (at /usr/lib/ruby/vendor_ruby/puppet/settings.rb:1071:in `each')
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                matthaus Past Haus
                Reporter:
                josh Josh Cooper
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support