Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2659

Puppet stops working with error 'Attempted to pop, but already at root of the context stack.'

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: PUP 3.6.1
    • Fix Version/s: PUP 3.6.2
    • Component/s: Modules
    • Labels:
      None
    • Environment:

      CentOS 6.5

    • Template:
    • Story Points:
      3
    • Sprint:
      Week 2014-5-21 to 2014-5-28, Week 2014-5-28 to 2014-6-4, Week 2014-6-4 to 2014-6-11
    • UX Priority:
      Critical

      Description

      After upgrading puppet to version 3.6.1, the following error occurs:

      Attempted to pop, but already at root of the context stack.
      

      And afterwards log is flooded with following message:

      no 'environments' in {:root_environment=>#<Puppet::Node::Environment:0x7fe1930f5a38 @manifest="/", @modulepath=[], @name=:"*root*", @watching=true, @config_version=nil>, :current_environment=>#<Puppet::Node::Environment:0x7fe1930f5a38 @manifest="/", @modulepath=[], @name=:"*root*", @watching=true, @config_version=nil>} at top of [[0, nil, nil]]
      

      This was not an issue in 3.6.0. Unfortunately this happens at seemingly random times, soon after starting the puppetmaster service.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                mikael.barfred Mikael Barfred
                Reporter:
                urbanius Wojciech Urbański
              • Votes:
                18 Vote for this issue
                Watchers:
                45 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support