Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2739

Deprecation warnings for legacy environment sections in puppet.conf are not disabled by a disable_warnings set in puppet.conf

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.6.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      The warnings for legacy sections in puppet conf come from lib/puppet/settings/config_file.rb. It is warning directly, and will need to be adjusted to register it's warnings with the main Settings, since we can't read the disable_warnings setting from puppet.conf while in the midst of parsing it.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                andy Andrew Parker
                Reporter:
                joshua.partlow Joshua Partlow
                QA Contact:
                Kurt Wall
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support