Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2742

Missing dependencies on Ubuntu Trusty 64 bit - ruby-rgen

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: PUP 3.6.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu Trusty Tahir 14.04 LTS

    • Template:

      Description

      On Ubuntu Trusty Tahir 14.04 LTS puppet is not installable

      The following packages have unmet dependencies:
      puppet-common : Depends: ruby-rgen (>= 0.6.5) but it is not installable
      E: Unable to correct problems, you have held broken packages.

      On Precise this package is provided in the dependencies repository at https://apt.puppetlabs.com/pool/precise/dependencies/r/ruby-rgen/ but for Trusty the dependencies repository is empty except for the Puppetlabs release deb

      https://apt.puppetlabs.com/pool/trusty/dependencies/

      root@vagrant:~# apt-cache depends puppet-common
      puppet-common

      Depends: ruby
      Depends: <ruby-interpreter>
      ruby2.0
      ruby1.9.1
      Depends: <libopenssl-ruby>
      Depends: <libopenssl-ruby1.9.1>
      libruby1.9.1
      Depends: libruby
      Depends: ruby-shadow
      Depends: <libshadow-ruby1.8>
      Depends: libaugeas-ruby
      ruby-augeas
      Depends: libaugeas-ruby1.9.1
      ruby-augeas
      Depends: libaugeas-ruby1.8
      ruby-augeas
      Depends: adduser
      Depends: lsb-base
      Depends: sysv-rc
      Depends: <file-rc>
      Depends: hiera
      Depends: facter
      Depends: ruby-rgen
      Depends: <libjson-ruby>
      Depends: ruby-json
      Suggests: ruby-selinux
      Suggests: <libselinux-ruby1.8>
      Suggests: librrd-ruby1.9.1
      Suggests: <librrd-ruby1.8>
      Recommends: lsb-release
      Recommends: debconf-utils
      Conflicts: <hiera-puppet>
      Breaks: puppet
      Breaks: puppetmaster
      Replaces: <hiera-puppet>
      puppet-common

      Apologies if I've reported this incorrectly but it is an issue which is stopping me using Puppet with Trusty in a new project.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              trevorrea Trevor Rea
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support