Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2745

Puppet 3.6.1 issue with Forge API v3

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.6.0, PUP 3.6.1
    • Fix Version/s: PUP 3.7.0
    • Component/s: PMT
    • Labels:
    • Template:
    • Story Points:
      2
    • Sprint:
      Week 2014-6-25 to 2014-7-9, 2014-07-23, 2014-08-06, 2014-08-20, 2014-09-03

      Description

      Getting this error on RHEL5 and RHEL6 when trying to install ghoneycutt/puppet. Broken on 3.6.0 and 3.6.1 but downgrading to 3.5.1 fixed the issue.

      [root@sbox09 ~]# puppet module install ghoneycutt/puppet --verbose --debug
      Notice: Preparing to install into /etc/puppet/modules ...
      Notice: Downloading from https://forgeapi.puppetlabs.com ...
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-puppet
      Debug: Error in ghoneycutt-puppet@2.1.2 parsing dependency puppetlabs-stdlib (Unparsable version range: ">= 3.2.x"); using empty range.
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-apache
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-firewall
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-stdlib
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-stdlib&limit=20&offset=20
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ripienaar-concat
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-concat
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=leinaddm-htpasswd
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-mysql
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-mysql&limit=20&offset=20
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=bodepd-create_resources
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-passenger
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-gcc
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-ruby
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-generic
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-backup
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-logwatch
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-certs
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-hosts
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-generic>= 1.0.0
      Error: bad URI(is not URI?): /v3/releases?module=ghoneycutt-generic>= 1.0.0
      Error: Try 'puppet help module install' for usage

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ben.hocker Ben Hocker
                QA Contact:
                John Duarte
              • Votes:
                1 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support