Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2878

puppet-kick.8.gz conflict upgrading from 2.7.26 to 3.6.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.6.2
    • Fix Version/s: PUP 3.7.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      0
    • Sprint:
      2014-07-23

      Description

      # apt-get install puppet facter puppet-common ruby-rgen
      Reading package lists... Done
      Building dependency tree       
      Reading state information... Done
      The following extra packages will be installed:
        hiera libjson-ruby ruby-json virt-what
      Suggested packages:
        puppet-el vim-puppet ruby-selinux libselinux-ruby1.8 librrd-ruby1.9.1 librrd-ruby1.8
      The following NEW packages will be installed
        hiera libjson-ruby ruby-json ruby-rgen virt-what
      The following packages will be upgraded:
        facter puppet puppet-common
      3 to upgrade, 5 to newly install, 0 to remove and 3 not to upgrade.
      Need to get 1,583 kB of archives.
      After this operation, 2,330 kB of additional disk space will be used.
      Do you want to continue [Y/n]? 
      (Reading database ... 97569 files and directories currently installed.)
      Preparing to replace puppet-common 2.7.26-1puppetlabs1 (using .../puppet-common_3.6.2-1puppetlabs1_all.deb) ...
      Unpacking replacement puppet-common ...
      dpkg: error processing /var/cache/apt/archives/puppet-common_3.6.2-1puppetlabs1_all.deb (--unpack):
       trying to overwrite '/usr/share/man/man8/puppet-kick.8.gz', which is also in package puppet 2.7.26-1puppetlabs1
      No apport report written because MaxReports has already been reached
                                                                          dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
      Preparing to replace puppet 2.7.26-1puppetlabs1 (using .../puppet_3.6.2-1puppetlabs1_all.deb) ...
       * Stopping puppet agent                                                                                                                                                                                                              [ OK ] 
      Unpacking replacement puppet ...
      Selecting previously unselected package ruby-json.
      Unpacking ruby-json (from .../ruby-json_1.6.3-1_i386.deb) ...
      Selecting previously unselected package libjson-ruby.
      Unpacking libjson-ruby (from .../libjson-ruby_1.6.3-1_all.deb) ...
      Selecting previously unselected package hiera.
      Unpacking hiera (from .../hiera_1.3.4-1puppetlabs1_all.deb) ...
      Selecting previously unselected package ruby-rgen.
      Unpacking ruby-rgen (from .../ruby-rgen_0.6.5-1puppetlabs1_all.deb) ...
      Selecting previously unselected package virt-what.
      Unpacking virt-what (from .../virt-what_1.11-1_i386.deb) ...
      Preparing to replace facter 1.6.18-1puppetlabs1 (using .../facter_2.0.2-1puppetlabs1_i386.deb) ...
      Unpacking replacement facter ...
      Processing triggers for man-db ...
      Processing triggers for ureadahead ...
      Errors were encountered while processing:
       /var/cache/apt/archives/puppet-common_3.6.2-1puppetlabs1_all.deb
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              melissa Melissa Stone
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support