Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2907

Regression when pluginsyncing external facts on Windows

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.7.0
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      2014-08-20

      Description

      Ticket PUP-2705 restored the ability for pluginsync to preserve permissions for external facts synced to facts.d. However, on Windows, it generates a deprecation warning, which users cannot fix:

      C:\work\puppet> bundle exec puppet agent -t
      ...
      Info: Retrieving pluginfacts
      Warning: Copying owner/mode/group from the source file on Windows is deprecated; use source_permissions => ignore.
         (at C:/cygwin64/lib/ruby/site_ruby/1.9.1/puppet/type/file/source.rb:133:in `block in copy_source_values')
      Notice: /File[C:/ProgramData/PuppetLabs/puppet/var/facts.d]/mode: mode changed '0700' to '0755'
      Info: Retrieving plugin
      Info: Loading external facts from C:/ProgramData/PuppetLabs/puppet/var/facts.d
      

      The plugin_handler should specify :use on posix, and :ignore on windows.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  josh Josh Cooper
                  QA Contact:
                  Erik Dasher
                • Votes:
                  2 Vote for this issue
                  Watchers:
                  8 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: