Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2926

Print version of failed catalog

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.6.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      When a catalog compilation fails, it would be great to get the catalog version

      Error: Could not retrieve catalog from remote server:
      Warning: Not using cache on failed catalog
      Error: Could not retrieve catalog; skipping run

      could become

      Error: Could not retrieve catalog version 'Deploy-Fri Jul 11 11:53:56 CEST 2014' from remote server:
      Warning: Not using cache on failed catalog
      Error: Could not retrieve catalog; skipping run

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              roidelapluie Julien Pivotto
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support