Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2940

Installing and using puppet with CentOS7 & RHEL7

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: PUP 3.5.0, PUP 3.6.0, PUP 3.6.2, PUP 3.7.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      RHEL7/CENTOS7

    • Template:

      Description

      Hi,

      Has anyone successfully installed and used puppet on Centos7/RHEL7.

      I have added the EL7 Puppet labs repo and installed the RPM and its installing ruby from the CentOS base repo which is version 2.0, added the below dependancies that have been installed.

      However when trying to run commands I am getting the below. I had to install RVM with 1.9.3 to get this far as the service would not start without this.

      Before adding RVM with 1.9.3 the commands were not bringing back anything and the service failed to to run.

      Details:

      Error:
      [root@localhost log]# puppet --version
      /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require': cannot load such file – json (LoadError)
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/module.rb:3:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/files.rb:1:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/templatewrapper.rb:1:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/scope.rb:6:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/methods.rb:2:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/ast/method_call.rb:2:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/ast.rb:115:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser/parser.rb:11:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/parser.rb:4:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet.rb:249:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/ruby/vendor_ruby/puppet/util/command_line.rb:12:in `<top (required)>'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:53:in `require'
      from /bin/puppet:3:in `<main>'

      Ruby Dependancies installed
      rubygem-json-1.7.7-20.el7.x86_64
      ruby-shadow-2.2.0-2.el7.x86_64
      ruby-libs-2.0.0.353-20.el7.x86_64
      ruby-irb-2.0.0.353-20.el7.noarch
      rubygem-psych-2.0.0-20.el7.x86_64
      ruby-2.0.0.353-20.el7.x86_64
      ruby-augeas-0.4.1-3.el7.x86_64
      rubygem-io-console-0.4.2-20.el7.x86_64
      rubygems-2.0.14-20.el7.noarch
      ruby-rgen-0.6.5-2.el7.noarch
      rubygem-rdoc-4.0.0-20.el7.noarch
      libselinux-ruby-2.2.2-6.el7.x86_64
      rubygem-bigdecimal-1.2.0-20.el7.x86_64

        Attachments

          Activity

            People

            Assignee:
            ghoneycutt garrett honeycutt
            Reporter:
            wingZero21 Mark Bell
            QA Contact:
            Kurt Wall
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support