Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-2941

Autorequire does not properly support Class resources as first-class citizens

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Template:

      Description

      Attempting to autorequire a class inside a custom type results in the autorequire being ignored. Since Classes are supposed to be treated as first-class resources, they should be autorequire-able like any other resource type.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                redmine.exporter redmine.exporter
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: