Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3073

Error message "Could not send report": appear when puppet client is pulling config from puppet master

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.6.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Puppet on Junos (Juniper device which has jpuppet package installed)

    • Template:
    • UX Priority:
      Normal

      Description

      Please find attached log files for more details

      Error message "Could not send report": appear when puppet client is pulling config from puppet master with vlan configuration i.e..vlan count greater than 460 and less than 700.
       
      root> show vlans         
       
      Routing instance        VLAN name             Tag          Interfaces
      default-switch          default               1        
                                                                  
       
      Pulling the config file from master which is having 500 vlans to be configured on client.
      ----------------------------------------------------------------------------------------
       
      +      }
      +      v-98 {
      +          description "Puppet created VLAN: v-98: 98";
      +          vlan-id 98;
      +      }
      +      v-99 {
      +          description "Puppet created VLAN: v-99: 99";
      +          vlan-id 99;
      +      }
      +  }
       
      Notice: JUNOS: OK: COMMIT success!  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> Error message is seen on puppet client
      Notice: Finished catalog run in 101.35 seconds
      Error: Could not send report: Stack overflow in regexp matcher: /\A(?: # ?: non-capturing group (grouping with no back references)
                       [\x09\x0A\x0D\x20-\x7E]            # ASCII
                     | [\xC2-\xDF][\x80-\xBF]             # non-overlong 2-byte
                     |  \xE0[\xA0-\xBF][\x80-\xBF]        # excluding overlongs
                     | [\xE1-\xEC\xEE\xEF][\x80-\xBF]{2}  # straight 3-byte
                     |  \xED[\x80-\x9F][\x80-\xBF]        # excluding surrogates
                     |  \xF0[\x90-\xBF][\x80-\xBF]{2}     # planes 1-3
                     | [\xF1-\xF3][\x80-\xBF]{3}          # planes 4-15
                     |  \xF4[\x80-\x8F][\x80-\xBF]{2}     # plane 16
                     )*\z/mxn
      %
       
       
      Vlans are getting configured on puppet client but above errors are seen.
      -----------------------------------------------------------------------
      root> show vlans | grep 500    
      default-switch          v-500                 500      
       
      {master:0}
      puppet@st-mojito2f-02>
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            ganesh634 Ganesh Nalawade
            QA Contact:
            Erik Dasher
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support