Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3082

Error in puppet module skeleton

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.0.0
    • Component/s: PMT
    • Labels:
    • Template:

      Description

      The puppet module skeleton specifies a Gemfile with the following line:

      puppetversion = ENV.key?('PUPPET_VERSION') ? "= #{ENV['PUPPET_VERSION']}" : ['>= 3.3']
      

      if you define an env var as PUPPET_VERSION="~> 3.6.0" as most people do when testing with travis, bundler will complain stating it cannot meet the requirements.

      Changing the line to:

      puppetversion = ENV.key?('PUPPET_VERSION') ? "#{ENV['PUPPET_VERSION']}" : ['>= 3.3']
      

      Fixes the issue.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              feniix Sebastian Otaegui
              QA Contact:
              Ryan Gard
              Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support