Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3141

PMT module list gives inaccurate warning message when module has bad semver

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Affects Version/s: PUP 3.7.0
    • Fix Version/s: None
    • Component/s: PMT
    • Labels:
      None
    • Template:
    • Story Points:
      1

      Description

      puppet module list gives an inaccurate error message about the version of a different depended-upon module when a module has a bad semver.

      $  puppet module list
      Warning: Missing dependency 'puppetlabs-stdlib':
        'anderson-ugg' (v0.1) requires 'puppetlabs-stdlib' (>= 1.0.0)
      /Users/anderson/.puppet/modules
      ├── anderson-ugg (v0.1)
      ├── ghoneycutt-hosts (v2.1.0)
      └── puppetlabs-stdlib (v4.3.2)
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              anderson Anderson Mills
              QA Contact:
              Eric Thompson
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support