Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3479

Windows ffi dependency fails for Ruby 2.1.3

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.7.1
    • Fix Version/s: PUP 4.0.0
    • Component/s: None
    • Template:
    • Story Points:
      1
    • Sprint:
      Platform Client 2014-12-17

      Description

      Ruby 2.1.x was released on Windows for the first time with Ruby 2.1.3 in September: https://www.ruby-forum.com/topic/5768030

      Running Ruby from source on Windows with Ruby 2.1.3 fails, because ffi 1.9.3 isn't compatible with Ruby 2.1.x. The ffi dependency needs to be updated to require ffi 1.9.5+ on all our projects that depend on it: at least puppet, facter, hiera.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  michael.smith Michael Smith
                  QA Contact:
                  Kurt Wall
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: