Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3480

Puppet does not have Python 3 package provider (pip3)

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.4.0, PUP 3.4.1, PUP 3.4.2, PUP 3.4.3, PUP 3.5.0, PUP 3.5.1, PUP 3.6.0, PUP 3.6.1, PUP 3.6.2, PUP 3.7.0, PUP 3.7.1
    • Fix Version/s: PUP 4.2.0
    • Labels:
    • Environment:

      All environments with python 3 installed

    • Template:
    • Story Points:
      1
    • Sprint:
      Client 2015-06-10
    • Release Notes:
      New Feature

      Description

      There is no way to install python 3 package in puppet without long exec blocks or some other hacks. Python 2 package provider is present in Puppet and works well.

      Python 2 package provider in Puppet master: https://github.com/puppetlabs/puppet/blob/master/lib/puppet/provider/package/pip.rb
      Openstack-Infra have made Python 3 provider that bases on Python 2 provider: https://github.com/openstack-infra/puppet-pip/blob/master/lib/puppet/provider/package/pip3.rb

      I tested Python 3 package provider from openstack-infra with following manifest and it worked:

      package { ['django==1.7']:
        ensure => present,
        provider => pip3,
        require => Package['python3-pip'],
      }
       
      package { ['uwsgi==2.0']:
        ensure => present,
        provider => pip3,
        require => Package['python3-pip'],
      }
      

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                Karmux Karmo Rosental
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: