Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3611

Implement install_options for nim package provider

    Details

    • Type: Improvement
    • Status: Accepted
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: PUP 3.4.2
    • Fix Version/s: None
    • Component/s: Types and Providers
    • Environment:

      AIX 7100-03-03 6100-02-09

    • Template:
    • Acceptance Criteria:
      • Can pass install_options parameters to nim provider.
    • Team:
      Platform OS
    • Story Points:
      3

      Description

      The NIM provider has enough divergence from other package providers that it would be helpful to have support for an install_options hash, similar to gem, pip, and windows.

      Original description:
      The NIM package provider is missing a parameter for installp_bundle.
      It would be very helpful in many cases to install lpp_sources and specify
      with -a installp_bundle=yyyyyyy only a subset of the whole lpp_source.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                rmueck Ruediger Mueck
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: