Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3724

Use ffi 1.9.6 for Ruby 2.1 in puppet-win32-ruby

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.0.0
    • Component/s: Windows
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Windows 2015-01-14

      Description

      ffi was bumped to 1.9.5 in puppet-win32-ruby. That version had an issue exclusive to Ruby 2.1 (https://github.com/ffi/ffi/issues/375), so a Ruby 2.1 version of puppet-win32-ruby should use ffi 1.9.6

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              michael.smith Michael Smith
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support