Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3737

Can't Install Puppet Gem on Windows64 Bit Ruby 1.9.3 and 2.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 3.7.1, PUP 3.7.3
    • Fix Version/s: PUP 3.7.4
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1

      Description

      Get the following dependency errors on windows

      D:\Wng.IAC\Modules\wn-facts>gem install puppet
      ERROR: While executing gem ... (Gem::DependencyError)
      Unable to resolve dependencies: puppet requires ffi (= 1.9.3); win32-service requires ffi (>= 0); win32-process requires ffi (>= 1.0.0); win32-eventlog requires ffi (>= 0); facter requires ffi (~> 1.9.5); win32-security requires ffi (>= 0); win32-dir requires ffi (>= 1.0.0)

      D:\Wng.IAC\Modules\wn-facts>gem install puppet -v 3.7.2
      ERROR: While executing gem ... (Gem::DependencyError)
      Unable to resolve dependencies: puppet requires ffi (= 1.9.3); win32-service requires ffi (>= 0); win32-process requires ffi (>= 1.0.0); win32-eventlog requires ffi (>= 0); facter requires ffi (~> 1.9.5); win32-security requires ffi (>= 0); win32-dir requires ffi (>= 1.0.0)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              mldasco Mark Dasco
              QA Contact:
              Eric Thompson
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support