Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-3927

(Regression) Redhat service provider is being used on systemd-based Fedora systems

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: PUP 3.7.4
    • Fix Version/s: PUP 3.7.5
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      3
    • Sprint:
      RE 2015-02-11, RE 2015-02-25

      Description

      In 3.7.4 we made changes to the Redhat service provider (PUP-1343) which cannot be run for systemd based services. The systemd provider is the default for redhat v7, but hasn't been enabled for Fedora. This means that enabling services on Fedora will fail.

      The fix for this should just be to enable the systemd provider for the relevant releases of Fedora.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                scott.garman Scott Garman
                QA Contact:
                Eric Thompson
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support