Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4011

Spec test failure on ruby 1.8.7: ProviderSystemd should not be the default provider on rhel4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      ruby-1.8.7-p374

    • Template:
    • Story Points:
      2
    • Sprint:
      RE 2015-02-25

      Description

      CI spec test failure on master branch: See CI failure

      Error Message

      failed Puppet::Type::Service::ProviderSystemd should not be the default provider on rhel4
      

      Stacktrace

              not all expectations were satisfied
      unsatisfied expectations:
      - expected exactly once, not yet invoked: Facter.value(:operatingsystem)
      satisfied expectations:
      - allowed any number of times, not yet invoked: Signal.trap(any_parameters)
      - allowed any number of times, not yet invoked: Puppet::Type::Service.defaultprovider(any_parameters)
      - allowed any number of times, not yet invoked: Puppet::Type::Service::ProviderSystemd.which('systemctl')
      - expected at least once, invoked twice: Facter.value(:operatingsystemmajrelease)
      - expected at least once, invoked 3 times: Facter.value(:osfamily)
       
      ./spec/unit/provider/service/systemd_spec.rb:36
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                john.duarte John Duarte
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support