Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4113

Migrate and Preview 3.8 Language to 4.0

    Details

    • Type: Epic
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 3.8.0
    • Component/s: None
    • Labels:
      None
    • Epic Name:
      Migration to 4.0
    • Template:
    • Release Notes:
      New Feature

      Description

      Provide mechanisms and tools to aid users migrating to 3.8.0 with future parser from their 3.x compliant logic to make the transition smoother.

      The functionality consists of instrumentation of the 3.8 validation framework and evaluator logic as well as a separate module that contains a preview sub command and the diff and additional migration validation logic. This module is available only in PE.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                henrik.lindberg Henrik Lindberg
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support