Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4131

Gem version specifiers are not idempotent

    Details

    • Template:
    • Story Points:
      1
    • Sprint:
      Client 2015-06-10
    • Release Notes:
      Bug Fix

      Description

      Original

      It would be useful to support Gem version requirements in package resources, such as:

          package { 'hiera-eyaml-gpg':
            ensure   => '>= 0.5.rc1',
            provider => gem,
          }
      

      or

          package { 'ruby_gpg':
            ensure   => '~> 0.3',
            provider => gem,
          }
      

      Updated

      Previously, if the manifest specified a gem version as a constraint, e.g. ~> 0.3, as opposed to an explicit version 1.2.3 or latest, then the gem provider was not idempotent, and would attempt to reinstall the gem each time. With this fix, the gem provider is idempotent when using a gem version constraint.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  raphink Raphaël Pinson
                  QA Contact:
                  Eric Thompson
                • Votes:
                  4 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: