Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4325

Gem provider fails to run on Ruby 2.1.5 / Puppet 4 on Windows

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Windows
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Windows 2015-04-08

      Description

      The gem package provider on Windows shells out to Ruby to list / install gems.

      Unfortunately, there is a bug in Ruby 2.1.5 and gem, which prevents the gem package provider from being able to install anything

      Current environment:

      C:\source\puppet [master...origin/master +13 ~0 -0 !]> ruby --version
      ruby 2.1.5p273 (2014-11-13 revision 48405) [x64-mingw32]
       
      C:\source\puppet [master...origin/master +13 ~0 -0 !]> gem --version
      2.2.2
       
      C:\source\puppet [master...origin/master +13 ~0 -0 !]> chcp
      Active code page: 1252
       
      C:\source\puppet [master...origin/master +13 ~0 -0 !]> bundle exec puppet --version
      DL is deprecated, please use Fiddle
      DL is deprecated, please use Fiddle
      4.0.0-rc2
      

      The repro is trivial when running Puppet 4.0.0-rc2 from source against Ruby 2.1.5, but even more trivial with Ruby itself, as this is where the problem lies:

      C:\source\puppet [master...origin/master +13 ~0 -0 !]> gem install foo
      BUG: expand_environ triggered with %SystemRoot%\System32\drivers\etc
      ERROR:  While executing gem ... (Encoding::CompatibilityError)
          incompatible character encodings: UTF-8 and UTF-16LE
      

      Note that this was run against RubyInstaller's Ruby 2.1.5 in a dev environment. Verification should still be made against the custom Ruby that Puppet bundles and ships from puppet-win32-ruby

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              ethan Ethan Brown
              Reporter:
              ethan Ethan Brown
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support