Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4497

Yum package provider: ensure => latest fails when obsoleted packages are present

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.0.0
    • Fix Version/s: PUP 4.2.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      3
    • Sprint:
      RE 2015-06-03
    • Release Notes:
      Bug Fix

      Description

      When the yum provider has packages marked as obsoleted, the yum provider fails to ensure => latest on a package.

      [root@localhost provider]# puppet apply -e "package{'puppet-agent': ensure => 'latest'}"
      Notice: Compiled catalog for centos-70-x64.ineu.us in environment production in 0.79 seconds
      Error: Could not get latest version: undefined method `[]' for nil:NilClass
      Error: /Stage[main]/Main/Package[puppet-agent]/ensure: change from 1.0.1-1.el7 to latest failed: Could not get latest version: undefined method `[]' for nil:NilClass
      Notice: Applied catalog in 0.38 seconds
      

      To duplicate, bring up a CentOS7.0 VM, install puppet-agent 1.0.1

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                melissa Melissa Stone
                Reporter:
                jlambert Justin Lambert
              • Votes:
                1 Vote for this issue
                Watchers:
                10 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support