Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4503

systemd should be the default provider for Debian Jessie

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: PUP 4.2.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      3
    • Sprint:
      RE 2015-05-20
    • Release Notes:
      New Feature

      Description

      There is, unfortunately, a bug in systemd on Debian Jessie where older sysvinit scripts can't detect the enabled status. Therefore you should not just enable that as the default.

      I wrote a version of a provider based on systemd that can check enabled via both systemd AND sysvinit and then the enable/disable in systemd does the right thing.

      https://gist.github.com/leepa/9818b46b29b161413824

      This is a bug because Puppet 3.7.5 does not work correctly at all on Debian Jessie because of this.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              melissa Melissa Stone
              Reporter:
              leepa Lee Packham
              Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support