Uploaded image for project: 'Puppet'
  1. Puppet
  2. PUP-4601

Puppet gem should require at least 1.9+ ruby version

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: PUP 4.0.0
    • Fix Version/s: PUP 4.2.0
    • Component/s: None
    • Labels:
    • Template:
    • Story Points:
      1
    • Sprint:
      Client 2015-05-27
    • Release Notes:
      Bug Fix

      Description

      The puppet gem specification should require a ruby that is >= 1.9.3 because 1.8 is no longer supported in Puppet 4.

      This will prevent the 4.x gem from installing on systems that only have a 1.8 ruby.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  peter.huene Peter Huene
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: